Opened 5 years ago

Closed 5 years ago

#1169 closed (invalid)

DDNS fails when PPTP server is enabled in V24PreSP2

Reported by: Mastersoft Owned by: somebody
Keywords: Cc:

Description

The DDNS failed to update when the PPTP server is enabled. I have checked versions from V24 PreSP2 r12427 to r12533.

Thu Jan 1 00:00:25 1970: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater. Thu Jan 1 00:00:25 1970: INADYN: IP read from cache file is '84.59.11.28'. No update required. Thu Jan 1 00:00:55 1970: INADYN:IP: Error '0x2' resolving host name 'checkip.dyndns.org' Thu Jan 1 00:00:55 1970: W: DYNDNS: Error 'RC_IP_INVALID_REMOTE_ADDR' (0x12) when talking to IP server Thu Jan 1 00:00:55 1970: W:'RC_IP_INVALID_REMOTE_ADDR' (0x12) updating the IPs. (it 0)

Change History (5)

comment:1 Changed 5 years ago by BrainSlayer

  • Resolution set to invalid
  • Status changed from new to closed

i dont think that this has something todo with your pptp server. its more likelly that your dns config is faulty. i have enabled pptp server and dyndns works

Wed Jul 22 14:45:53 2009: INADYN: Started 'INADYN Advanced version 1.96-ADV' - dynamic DNS updater. Wed Jul 22 14:45:53 2009: INADYN: IP read from cache file is '93.218.175.94'. No update required. Wed Jul 22 14:45:53 2009: I:INADYN: IP address for alias 'brainslayer.dyndns.org' needs update to '93.218.187.184' Wed Jul 22 14:45:53 2009: I:INADYN: Alias 'brainslayer.dyndns.org' to IP '93.218.187.184' updated successfully.

comment:2 Changed 5 years ago by Mastersoft

  • Resolution invalid deleted
  • Status changed from closed to reopened

I can't understand that the problem is my dns config when DDNS runs fine when PPTP Server is disabled and when I enabled PPTP Server it doesn't? The dns config is always the same or not?

Please take a look at the routing table in the wrt54 when PPTP Server is disabled: root@GW-ATN:~# route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 84.58.224.1 * 255.255.255.255 UH 0 0 0 ppp0 10.1.1.0 * 255.255.255.0 U 0 0 0 br0 169.254.0.0 * 255.255.0.0 U 0 0 0 br0 127.0.0.0 * 255.0.0.0 U 0 0 0 lo default dslb-084-058-22 0.0.0.0 UG 0 0 0 ppp0 root@GW-ATN:~# This command ends after 1 secound I can ping IPs in internet and DNS resolution is running fine. In /tmp/resolv.dnsmasq are two correct dns servers stored. nameserver 195.50.140.178 nameserver 195.50.140.114

and now is PPTP Server enabled without any other changes:

root@GW-ATN:~# route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 84.58.224.1 * 255.255.255.255 UH 0 0 0 ppp0 10.1.1.0 * 255.255.255.0 U 0 0 0 br0 169.254.0.0 * 255.255.0.0 U 0 0 0 br0 127.0.0.0 * 255.0.0.0 U 0 0 0 lo

not until 30 secounds!! the route command ends with: root@GW-ATN:~# route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 84.58.224.1 * 255.255.255.255 UH 0 0 0 ppp0 10.1.1.0 * 255.255.255.0 U 0 0 0 br0 169.254.0.0 * 255.255.0.0 U 0 0 0 br0 127.0.0.0 * 255.0.0.0 U 0 0 0 lo default 84.58.224.1 0.0.0.0 UG 0 0 0 ppp0 root@GW-ATN:~# I can ping IPs in internet but DNS resolution doesn't run. In /tmp/resolv.dnsmasq are only the route ip as dns server stored. nameserver 10.1.1.254

When I check the same configuration in V24SP1 with PPTP Server enabled in /tmp/resolv.dnsmasq stored this nameservers: nameserver 195.50.140.178 nameserver 195.50.140.114

I think that is the reason for the problems with DDNS. Are you too?

comment:3 Changed 5 years ago by Crusader

  • Resolution set to worksforme
  • Status changed from reopened to closed

DDNS on 12461 is working fine here with PPTP server enabled, too. So seems to be an individual problem.

comment:4 Changed 5 years ago by Mastersoft

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It looks like the "individual" of the bug is to enable DHCP Forwarding to a local DHCP server on the subnet. When DHCP Forwarding and PPTP Server is enabled the DDNS can't update after rebooting the router. Disable PPTP and/or DHCP Forwarding resolves the DDNS function.

comment:5 Changed 5 years ago by BrainSlayer

  • Resolution set to invalid
  • Status changed from reopened to closed

running dhcp forwarding to a local dhcp server is just stupid and wrong. dhcp forwarding is made to use remote dhcp servers as dhcp source, but these servers must support multiple subnets

Note: See TracTickets for help on using tickets.