Opened 4 years ago

Closed 23 months ago

#1837 closed (wontfix)

Problems DNSMasq

Reported by: truthx Owned by:
Keywords: Cc:

Description

Enabling checkbox "Use DNSMasq for DNS" does not start automatically the service DNSMasq, although "Use DNSMasq for DHCP" starts the service DNSMasq automatically. DNSMasq starts handing out IP of 192.168.1.139, next 192.168.1.150 and etc., that is, in no particular order, uDHCPd gives the correct IP.

DIR-300 B1, build 13064 - build 15506

Change History (2)

comment:1 Changed 4 years ago by phuzi0n

"Use DNSMasq for DNS" is dependent on "Use DNSMasq for DHCP" being enabled. The real bug is that it doesn't get grayed out when "Use DNSMasq for DHCP" is unchecked.

DNSMasq handing out IP's pseudo-randomly is not a bug, it's a feature.

comment:2 Changed 23 months ago by Sash

  • Resolution set to wontfix
  • Status changed from new to closed

first of all is dnsmasq a dns resolver and NOT an dhcp server so the ddwrt behaviour is correct imho

Note: See TracTickets for help on using tickets.