Opened 3 years ago

Closed 3 years ago

#2339 closed (wontfix)

ip neigh seems to be broken in recent builds (18024)

Reported by: code65536 Owned by:
Keywords: Cc:

Description (last modified by code65536)

Update: Just use arp instead of ip neigh if you are trying to set up a broadcast address for WOL. E.g., arp -i br0 -s 192.168.1.254 FF:FF:FF:FF:FF:FF

STR: 1) SSH/telnet in 2) Run "ip neigh show"

Expected: There is usually something to show

Actual: Nothing

This adversely affects WOL, as ip neigh is often used to create a broadcast IP to which a WOL packet could be port-forwarded. (http://www.dd-wrt.com/wiki/index.php/Wake-on-LAN_(tutorial)). According to discussions on the forum, this problem was present in 17949. I personally have tested this only in build 18024 on an Asus RT-N12.

dd-wrt.v24-18024_NEWD-2_K2.6_mini_RT-N12.trx

Change History (3)

comment:1 Changed 3 years ago by code65536

  • Description modified (diff)

comment:2 Changed 3 years ago by code65536

Hmm, this bug probably has the same root cause as bug #2288.

comment:3 Changed 3 years ago by code65536

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from new to closed

ip neigh broke because ip was replaced by busybox's ip, which does not implement neigh. But busybox appears to implement arp, which can do the same things as ip neigh, so I'll go ahead and mark this as wontfix.

Note: See TracTickets for help on using tickets.