Opened 22 months ago

Last modified 2 weeks ago

#4742 new

Upgrading via web-interface bricks WZR-HP-G300NH

Reported by: KrypteX Owned by: kong
Keywords: Cc:

Description

This has been an ongoing issue with recent builds r27xxx on WZR-HP-G300NH. Webflash upgrade bricks it; can be flashed only by TFTP using the factory-to-ddwrt file.

Additionally, the NVRAM fills up to the max and a the NVRAM backup file is only 8 bytes.

Several reports for this one:

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=974296#974296

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=974609#974609

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=974612#974612

Change History (31)

comment:2 Changed 20 months ago by universal

OK, some Progress to avoid bricking.

Cant use wzr-hp-g300nh-dd-wrt-webupgrade-MULTI.bin ever, dont touch it its the devil and will brick your WZR-HP-G300NH since ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2013/2014/03-13-2014-r23720/buffalo_wzr-hp-g300nh/

The only way to flash upgrade this router without bricking is TFTP the buffalo_to_ddwrt_webflash-MULTI.bin to 192.168.11.1 (upgrade from DDWRT to DDWRT)

Configuration wise you are royally screwed, even more so if like me your network is huge. just the static IP assignments take an hour.

WOULD be nice if you could just upload the /tmp configuration files via ssh for at least the static ip assignments but that doesnt work either. Also you cant upload some script either since nvram config commands are useless now so your only chance is via UI one by one.

I hope someone is looking at this its been over a year with this issue now.

Last edited 20 months ago by universal (previous) (diff)

comment:3 Changed 20 months ago by indigo

Hi, I've been bitten by this as well. The unavailability of webflash is not that much of a problem here, but the nvram problem is. I now decided to switch to openwrt because of it; the new chaos calmer flash worked painlessly on the device (did it via ssh / mtd). However, that's not why I add this comment: Before the switch over I was running build 25203 (2014/10/29), i.e. significantly newer than above mentioned. I am very sure I webflashed it initially (later when bricking, of course had to use tftp to get back to it) and nvram backup definetely works with it. It was running very smooth for over half a year (and previous builds before that - thank you dd-wrt devs)! Main reason to switch away from it for me was to get openssl updates. I hope too someone finds the cause of this issue and it gets fixed!

Last edited 20 months ago by indigo (previous) (diff)

comment:4 Changed 18 months ago by universal

Related and still unfixed http://svn.dd-wrt.com/ticket/3894

comment:5 Changed 18 months ago by KrypteX

  • Resolution set to provide more info and reopen
  • Status changed from new to closed

NVRAM-related issues fixed in r28078,r28082-r28083 for Atheros and in r28085,r28102-r28108,r28209 for Broadcom. See related tickets #4724, #4883, #4882.

Additionally, NVRAM backup variables are sorted with r28138-r28139.

Please reopen if problem persists on WZR-HP-G300NH (or other Atheros-based units) with latest build r28211.

Last edited 17 months ago by KrypteX (previous) (diff)

comment:6 Changed 18 months ago by KrypteX

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

r28211 webflash still bricks WZR-HP-G300NH http://www.dd-wrt.com/phpBB2/viewtopic.php?p=992677#992677

The NVRAM backup of only 8 bytes for this Atheros-based unit, may be the same NVRAM bug which was recently fixed for Broadcom/MIPS http://svn.dd-wrt.com/ticket/4724#comment:3

Last edited 17 months ago by KrypteX (previous) (diff)

comment:8 Changed 17 months ago by KrypteX

  • Resolution set to fixed
  • Status changed from reopened to closed

NVRAM display/backup for Atheros units with oversized NVRAM is fixed in r27247-r27248. Thank you !

Version 0, edited 17 months ago by KrypteX (next)

comment:9 Changed 17 months ago by KrypteX

  • Resolution fixed deleted
  • Status changed from closed to reopened

Webupgrade from r28320 to r28366 still bricks the WZR-HP-G300NH http://www.dd-wrt.com/phpBB2/viewtopic.php?p=994956#994956

It has been determined that the webupgrade file (ddwrt-to-ddwrt) bricks this unit for all builds since r27320 http://www.dd-wrt.com/phpBB2/viewtopic.php?p=994620#994620

Related ticket: #3894

Last edited 17 months ago by KrypteX (previous) (diff)

comment:10 Changed 17 months ago by KrypteX

Last edited 17 months ago by KrypteX (previous) (diff)

comment:11 Changed 17 months ago by KrypteX

  • Resolution set to fixed
  • Status changed from reopened to closed
Last edited 17 months ago by KrypteX (previous) (diff)

comment:12 Changed 17 months ago by universal

Its not fixed going from r28417 to r28444 via webupgrade using wzr-hp-g300nh-dd-wrt-webupgrade-MULTI causes the router to go on a continuous and endless reboot loop.

Last edited 7 months ago by universal (previous) (diff)

comment:13 Changed 17 months ago by universal

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:14 Changed 17 months ago by universal

and again another brick in the wall, this time with with erase nvram/reboot before and after and webupgrading from r28444 to r28493 http://www.dd-wrt.com/phpBB2/viewtopic.php?p=996791#996791

Best stick to tftp for upgrading ddwrt to ddwrt, its safe, reliable and easy.

Last edited 17 months ago by universal (previous) (diff)

comment:15 Changed 15 months ago by universal

  • Summary changed from Webflash bricks WZR-HP-G300NH. NVRAM backup only 8 bytes to Webflash UPGRADE bricks WZR-HP-G300NH

the nvram 8 bytes has been fixed but the webupgrade brick is still valid,

I think 1 hour of waiting while the router reboots 20 times is a good indicator that its bricked.

since r28444 Ive tried webupgrades first and all brick and then TFTP which never failed so far.

comment:16 Changed 14 months ago by universal

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

comment:17 Changed 14 months ago by universal

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

comment:19 Changed 14 months ago by universal

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

comment:20 Changed 14 months ago by universal

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

Still applicable in 29193 --- 2016/03/02 ----

comment:21 Changed 13 months ago by universal

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

comment:22 Changed 13 months ago by universal

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

comment:23 Changed 13 months ago by universal

  • Owner set to Brainslayer
  • Status changed from reopened to new

comment:24 Changed 13 months ago by universal

Still applicable at 29346 --- 2016/03/25 ---

Last edited 13 months ago by universal (previous) (diff)

comment:25 Changed 13 months ago by universal

  • Resolution set to provide more info and reopen
  • Status changed from new to closed

comment:26 Changed 13 months ago by universal

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

comment:27 Changed 7 months ago by universal

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

comment:28 Changed 7 months ago by universal

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

Still an issue at r30681 http://www.dd-wrt.com/phpBB2/viewtopic.php?p=1048958#1048958

this issue is well over a year now with no solution in sight.

comment:29 Changed 2 weeks ago by positronic

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

comment:30 Changed 2 weeks ago by positronic

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened
  • Summary changed from Webflash UPGRADE bricks WZR-HP-G300NH to Upgrading via web-interface bricks WZR-HP-G300NH

Full report at http://www.dd-wrt.com/phpBB2/viewtopic.php?p=1074966#1074966

Copy and pasted here for convenience of developers or whoever it is that reads these.

Router: Buffalo WZR-HP-G300NH Firmware: DD-WRT v3.0-r31825 std (04/06/17) Kernel: Linux 3.10.96 #16689 Mon Feb 1 01:10:30 CET 2016 mips Status: OK after TFTP recovery / TFTP FW upgrade Reset: erase nvram Errors: Brick on webupgrade

As far as I can tell, despite not being a full comprehensive test of all Firmware functions, the basic stuff works OK, WIFI stability seems solid and there are no disconnects so far after 24 hours of flashing.

Only issue is upgrading from r29346 to r31825 via web interface bricks unit.

Originally I was on Buffalo DDWRT official firmware version V24-SP2 build r19484 Beta and it web upgraded to r29346 just fine .

comment:31 Changed 2 weeks ago by positronic

  • Owner changed from Brainslayer to kong
  • Status changed from reopened to new
Note: See TracTickets for help on using tickets.