Opened 17 months ago

Last modified 2 weeks ago

#5275 reopened

dir-862L as wds station uses bogus mac

Reported by: tatsuya46 Owned by:
Keywords: Cc:

Description

dir-862L as a wds station on all builds uses bogus mac 00:03:07:12:34:56. this causes problems when a user has more than 1 dir-862L and tries to connect them as wds station to the same wds host on 5ghz (ath10k).

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=1022201#1022201

also on the status -> sysinfo page wireless mac on the wds station is blank, same as on the wireless status page.

when running as client/client bridge/ap/wds ap mac is shown correctly.

Attachments (2)

dir-862Lr28374ath1mac.png (14.4 KB) - added by tatsuya46 17 months ago.
dir-862Lbogusmac.png (19.7 KB) - added by tatsuya46 17 months ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 17 months ago by tatsuya46

if the problem is in ath10k fw, what about switching ddwrt (both 10.2.4 & 10.4) to ath10k "CT" fw? it seems to be a free modified fw promising fixes over stock qca fw, have we tried it?

comment:2 Changed 17 months ago by BrainSlayer

Resolution: provide more info and reopen
Status: newclosed

the CT 10.2.4 crashes and is unstable. by the way, we are co developing this firmware with candelatech. dont know you're problem. i have never seen such a issue. mac is correct here in my device

comment:3 Changed 17 months ago by tatsuya46

Resolution: provide more info and reopen
Status: closedreopened

reproduction:

  • set dir-862L as wds station using 5ghz radio only to a qca wds ap
  • on status page of the dir-862L wds station mac address is missing like in the screenshot
  • on the wds host the mac of the dir-862L is always 00:03:07:12:34:56

on 2.4ghz the mac is normal this is only on 5ghz. the problem occurs when u have more than 1 dir-862L set as wds station to the same wds ap, cause they all appear with the same 00:03:07:12:34:56 mac, they kick eachother off upon connecting. see the forum link in ticket post.

Changed 17 months ago by tatsuya46

Attachment: dir-862Lr28374ath1mac.png added

comment:4 Changed 17 months ago by BrainSlayer

looks like a mac. but not bogus. your screenshot does not show 00:03:07:12:34:56

comment:5 Changed 17 months ago by tatsuya46

that shows the real mac doesnt appear, on the top where it says mac address on the dir-862L as wds station.

here on the wds ap, the dir-862L wds station is seen as 00:03:07:12:34:56. the real mac should be 6C:19:8F:F0:89:E0 (both bands).

Last edited 17 months ago by tatsuya46 (previous) (diff)

Changed 17 months ago by tatsuya46

Attachment: dir-862Lbogusmac.png added

comment:6 in reply to:  2 Changed 17 months ago by tatsuya46

Replying to BrainSlayer:

the CT 10.2.4 crashes and is unstable. by the way, we are co developing this firmware with candelatech.

nice. now im curious. are u eventually working towards a "good" ath10k fw? with working TX rate etc? i know u told me qualcomm atheros was going to give u the source code to ath10k fw a year ago or so, but never did. so now ur developing ur own ath10k fw?

have u seen the "code aurora" fw versions? dont know, maybe codeauora = candelatech?

here: https://us.codeaurora.org/cgit/quic/qsdk/oss/firmware/ath10k-firmware/plain/10.4/

& here: https://us.codeaurora.org/cgit/quic/qsdk/oss/firmware/ath10k-firmware/plain/10.2.4

Last edited 17 months ago by tatsuya46 (previous) (diff)

comment:7 Changed 17 months ago by tatsuya46

Resolution: invalid
Status: reopenedclosed

comment:8 Changed 17 months ago by tatsuya46

Resolution: invalid
Status: closedreopened

comment:9 Changed 17 months ago by BrainSlayer

Resolution: provide more info and reopen
Status: reopenedclosed

i used codeaurora fw in almost all builds. but tested also others and candelatech is something completelly different. ben grear is working with us on these firmwares but they arent stable, but still based on the official qca sourcecodes provided to us

but to be honest. i have a dir862, but i cannot reproduce your issue at all. mac is shown correct. could it be that your whole mac data is invalid. because no matter if ap mode or wds sta mode, the mac is the same here

comment:10 Changed 17 months ago by BrainSlayer

check also if you have configured mac cloning or something like that. that will apply too

comment:11 Changed 17 months ago by BrainSlayer

send me a backup file with email. i want to check some settings

comment:12 Changed 17 months ago by tatsuya46

mac cloning is off, sent the email.

comment:13 Changed 17 months ago by tatsuya46

Resolution: provide more info and reopen
Status: closedreopened

comment:14 Changed 15 months ago by tatsuya46

Resolution: invalid
Status: reopenedclosed

comment:15 Changed 15 months ago by tatsuya46

Resolution: invalid
Status: closedreopened

comment:16 Changed 15 months ago by tatsuya46

did u get my email? any update? bogus mac is still being used

comment:17 Changed 15 months ago by ian5142

I don't know about bogus mac but my 862L A1, setup as a WDS Station, both bands have the same mac. All my other routers the 2 bands are slightly different. Is that normal?

comment:18 Changed 15 months ago by tatsuya46

the wds station must be on the ath10k 5ghz radio, if ur using 2.4ghz mac is normal

comment:19 Changed 11 months ago by tatsuya46

Resolution: invalid
Status: reopenedclosed

comment:20 Changed 11 months ago by tatsuya46

Resolution: invalid
Status: closedreopened

comment:21 Changed 11 months ago by tatsuya46

remains on r30709

comment:22 Changed 8 months ago by tatsuya46

Resolution: invalid
Status: reopenedclosed

comment:23 Changed 8 months ago by tatsuya46

Resolution: invalid
Status: closedreopened

comment:24 Changed 2 weeks ago by tatsuya46

Resolution: invalid
Status: reopenedclosed

comment:25 Changed 2 weeks ago by tatsuya46

Resolution: invalid
Status: closedreopened
Note: See TracTickets for help on using tickets.