Opened 14 months ago

Last modified 2 months ago

#5279 reopened

ath10k 10.4-3.2 5ghz drops wds stations every hour

Reported by: tatsuya46 Owned by:
Keywords: Cc:

Description

r29264 the last build before it started, the 5ghz radio almost never, 1/10 times picks up other networks in site survey, even if the other router is in the same room with los.

on other routers, they rarely pick up the 5ghz network by site survey from the ea8500. previously none of these 2 issues ever happened. sometimes connecting clients like a phone or pc have a long delay before detecting the 5ghz network, or only join the 2.4ghz now.

wds station devices connected to the ea8500 wds ap by 5ghz all drop out for multiple seconds at 1:00 hr uptime flat, every single time always 1 hr, all of them. key interval setting is default on all at 3600, wpa2 aes only, nothing has changed.

all of these only happen on the 5ghz radio, the 2.4 seems unaffected so far.

Change History (48)

comment:1 Changed 14 months ago by tatsuya46

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 14 months ago by tatsuya46

  • Resolution fixed deleted
  • Status changed from closed to reopened

all listed here is fixed with r29346 except the wds station drops. they still all drop at the same time every 1hr flat. r29264 is last before that happened. reverting the wds station (dir-862L, wndr4300 v1, anything) back does nothing, its the wds ap thats dropping every hr.

when the drop happens the wds station reports this:

  • ath1: deauthenticated from c0:56:27:1d:06:6c (Reason: 2=PREV_AUTH_NOT_VALID)
  • br0: port 2(ath1) entered disabled state
  • ath1: authenticate with c0:56:27:1d:06:6c
  • ath1: send auth to c0:56:27:1d:06:6c (try 1/3)
  • ath1: authenticated
  • ath1: associate with c0:56:27:1d:06:6c (try 1/3)
  • ath1: RX AssocResp? from c0:56:27:1d:06:6c (capab=0x11 status=0 aid=1)
  • ath1: associated
  • br0: port 2(ath1) entered forwarding state
  • br0: port 2(ath1) entered forwarding state
  • br0: port 2(ath1) entered forwarding state
Last edited 14 months ago by tatsuya46 (previous) (diff)

comment:3 Changed 14 months ago by tatsuya46

  • Summary changed from ea8500 5ghz stability issues since r29308 to ea8500 5ghz stability issues since r29308 (drops wds stations every hour)

comment:4 Changed 14 months ago by tatsuya46

still dropping wds stations every hour..r29362 with

ath1: deauthenticated from c0:56:27:1d:06:6c (Reason: 2=PREV_AUTH_NOT_VALID)

r29264 last (public) build before this started

Last edited 14 months ago by tatsuya46 (previous) (diff)

comment:5 Changed 14 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:6 Changed 14 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:7 Changed 14 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:8 Changed 14 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:9 Changed 14 months ago by tatsuya46

still dropping wds stations every hour..

Last edited 14 months ago by tatsuya46 (previous) (diff)

comment:10 Changed 14 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:11 Changed 14 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

remains. currently connected clients are working, but new clients struggle to detect the ssid broadcasting..this never happened with r29264 & below..wds hourly drops remain too

comment:12 Changed 14 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:13 Changed 14 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:14 Changed 14 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:15 Changed 14 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:16 Changed 14 months ago by tatsuya46

  • Summary changed from ea8500 5ghz stability issues since r29308 (drops wds stations every hour) to ea8500/ath10k 10.4 5ghz stability issues since r29308 (drops wds stations every hour)

comment:17 Changed 13 months ago by tatsuya46

remains with r29471

comment:18 Changed 13 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:19 Changed 13 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:20 Changed 13 months ago by tatsuya46

Last edited 13 months ago by tatsuya46 (previous) (diff)

comment:21 Changed 13 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:22 Changed 13 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:23 Changed 13 months ago by tatsuya46

r29264 still last build before it started kicking wds stations

comment:24 Changed 13 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:25 Changed 13 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:26 Changed 13 months ago by tatsuya46

Last edited 13 months ago by tatsuya46 (previous) (diff)

comment:27 Changed 13 months ago by tatsuya46

switched to client bridge in the mean time..this problem doesnt happen on client bridge. wds only.

comment:28 Changed 13 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:29 Changed 13 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:30 Changed 13 months ago by BrainSlayer

  • Resolution set to toovague
  • Status changed from reopened to closed

running wds ap -> wds sta with 2 ath10k devices since 1 week now. no drop.

comment:31 Changed 13 months ago by tatsuya46

  • Resolution toovague deleted
  • Status changed from closed to reopened

which ath10k fw does the wds ap run? if it runs 10.2.4 its fine. the problem is only on ath10k 10.4 fw hosts

comment:32 Changed 13 months ago by tatsuya46

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in r29631

comment:33 Changed 10 months ago by tatsuya46

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from ea8500/ath10k 10.4 5ghz stability issues since r29308 (drops wds stations every hour) to ath10k 10.4-3.2 5ghz drops wds stations every hour

this problem is back again with the r7800 as wds ap, wds station dir-862L dropping every 1 hr flat

comment:34 Changed 10 months ago by tatsuya46

remains r30356

comment:35 Changed 10 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:36 Changed 10 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:37 Changed 9 months ago by tatsuya46

remains on r30432

comment:38 Changed 9 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:39 Changed 9 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

it also drops ath9k wds stations so its not qca9880's fault, this is purely the wds ap r7800.. its the key renewal & easy to test, set it to 60 seconds and it drops every 1 minute, 300 seconds every 5 min etc..

with security disabled it works forever no drop but security disabled is not an option..

comment:40 Changed 9 months ago by tatsuya46

remains on r30471

comment:41 Changed 9 months ago by tatsuya46

setting key renewal interval to 0 on the wds ap is a workaround for now assuming its not ruining security..

comment:42 Changed 7 months ago by BrainSlayer

  • Resolution set to invalid
  • Status changed from reopened to closed

connection established since 7 hours since last reboot

comment:43 Changed 7 months ago by tatsuya46

with key renewal at 0 yes.. (ath10k ap --> ath10k sta. not ath9k ap --> ath10k sta). when key renew int is on it will drop on it everytime

comment:44 Changed 2 months ago by enryIT

this is an huge issue. i don't want to disable group rekeying, are there any other fixes? some patches for wpad?

comment:45 Changed 2 months ago by enryIT

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:46 Changed 2 months ago by tatsuya46

this is in firmware from qualcomm, disabling key renewal isnt that bad if u have a decent password (& wpa2 in itself is still not a 2 min crack like WEP)

comment:47 Changed 2 months ago by enryIT

so this must be reported to qualcomm. do you guys know where to?

comment:48 Changed 2 months ago by tatsuya46

try ath10k mailing list

Note: See TracTickets for help on using tickets.