Opened 7 months ago

Last modified 13 days ago

#5603 reopened

add mac address clone option for both wifi interfaces

Reported by: tatsuya46 Owned by:
Keywords: Cc:

Description

dir-862L has the same macs for both ath0 & ath1, using mac cloning changes both to the same mac since theres only one option for wireless mac cloning, & it gets applied to both, doesnt fix the problem.

because of the same mac on both radios its causing a bunch of problems for mobile DUAL BAND ONLY devices, including association issues, performance issues such as 2.4ghz capping at 802.11b throughput, & drop out issues. some recent change to ath9k MADE IT HATE 2 RADIOS WITH SAME MAC, it will not get along with it whatsoever, ath10k radio is fine with it, & single band only devices are fine as they cant see the other same ssid with same mac.

doing these commands does nothing, none change.

  • nvram set ath0macaddr=6C:19:8F:F1:58:48
  • nvram set ath1macaddr=6C:19:8F:F1:58:49
  • nvram commit
  • reboot

they only change in mac address clone option, & change together. there needs to be an option for separate 2.4ghz interface mac cloning & 5ghz interface mac cloning to work around this. now its impossible to have both bands running on the same ssid for roaming as one of them has to be different. to further complicate things dir-862L currently has wrong same macs now with the latest internal builds, all dir-862L units have 00:20:13:09:02:03 for both bands.

Attachments (2)

macclone_example.png (27.1 KB) - added by tatsuya46 7 months ago.
dlink.png (43.5 KB) - added by xfaith 6 months ago.
Sorry image is not the best. 2.4 shows C0:A0:BB:EC:F8:09 and 5GHZ C0:A0:BB:EC:F8:0B

Download all attachments as: .zip

Change History (39)

Changed 7 months ago by tatsuya46

comment:1 Changed 7 months ago by tatsuya46

there is some kind of massive RF clashing happening at dual band mobile devices cause of the same macs, devices are getting completely confused & performance falls back to 802.11b throughputs with high latency. wifi scanners are also tricked.

dupe macs are very, very bad

comment:2 Changed 7 months ago by tatsuya46

remains with r30771

comment:3 Changed 7 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from new to closed

comment:4 Changed 7 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:5 Changed 7 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:6 Changed 7 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:7 Changed 7 months ago by tatsuya46

remains on r30796

comment:8 Changed 7 months ago by BrainSlayer

  • Resolution set to wontfix
  • Status changed from reopened to closed

both macs are identical as specified by the vendor. no issue

comment:9 Changed 7 months ago by tatsuya46

  • Resolution wontfix deleted
  • Status changed from closed to reopened

lots of problems with dupe mac, its not specified by dlink. on stock firmware the macs are not the same & devices dont get confused.

setup ur dir-862L, have both ath0 & ath1 with the same ssid & password. connect ur iphone 6 to it, it should go to the 5ghz ac radio first, then move it away enough so the phone roams to the 2.4ghz radio. when it does so do a speed test on the phone, the results will be 802.11b like speeds with horrible latency. this is one way & the most serious way the dupe macs are broken. it also seems to have a memory leak cause of it. ath0 on & ath1 off, no memory leak. ath1 on & ath0 off, no memory leak. both radios on, memory leak (viewing gui over wan will accelerate this memory leak).

wifi scanners, windows, dual band devices all get tricked by the dupe macs. if its not an easy fix to get the radio macs different, can we at least have a mac clone option for both radios to override it manually.

Last edited 7 months ago by tatsuya46 (previous) (diff)

comment:10 Changed 7 months ago by ian5142

I have a DIR-862L and have the same issue. I use 2 different SSIDs and but the same password and encryption. The 862L is a WDS Station connected to my WDS AP (Main router). The 862L will reboot every few hours (setup to reboot if it loses connection from the main router, checks every 5 min). If I disable the 5GHz interface on the 862L, it becomes very stable. I can post a screen shot of the factory firmware showing different MACs on the 2 interfaces.

comment:11 Changed 7 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:12 Changed 7 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:13 Changed 7 months ago by tatsuya46

remains latest public & nightly. if this is not "easily" fixable, we need a hack or mac cloning option for both wifi interfaces, we need something to work around this problem. currently this is an 802.11ac router where i either have no 802.11ac, or no 2.4ghz, i cant use both radios cause of this..

comment:14 Changed 7 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:15 Changed 7 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:16 Changed 6 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:17 Changed 6 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

Changed 6 months ago by xfaith

Sorry image is not the best. 2.4 shows C0:A0:BB:EC:F8:09 and 5GHZ C0:A0:BB:EC:F8:0B

comment:18 Changed 6 months ago by xfaith

I am having the same issue with the 2.4/5 Wifi bands. Both are showing the same MAC address under DDWRT 300082. I re-installed stock and both bands show different MAC address. The image is not the best but it shows 2.4 shows C0:A0:BB:EC:F8:09 and 5GHZ C0:A0:BB:EC:F8:0B.

Under DDWRT the MAC address: C0:A0:BB:EC:F8:09 shows for both. If I use MAC Cloning then the address: C0:A0:BB:EC:F8:0B is shows as available.

comment:19 Changed 6 months ago by xfaith

Wanted to add the the info from IFCONFIG under ADMIN/COMMAND.

ath0 Link encap:Ethernet HWaddr C0:A0:BB:EC:F8:09

ath0.1 Link encap:Ethernet HWaddr C2:A0:BB:EC:F8:09

ath1 Link encap:Ethernet HWaddr 00:03:07:12:34:56

ath1.1 Link encap:Ethernet HWaddr C2:A0:BB:EC:F8:09

br0 Link encap:Ethernet HWaddr C0:A0:BB:EC:F8:0A

br0:0 Link encap:Ethernet HWaddr C0:A0:BB:EC:F8:0A

eth0 Link encap:Ethernet HWaddr C0:A0:BB:EC:F8:0A eth1 Link encap:Ethernet HWaddr C0:A0:BB:EC:F8:0A

comment:20 Changed 6 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:21 Changed 6 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:22 Changed 6 months ago by tatsuya46

  • Summary changed from add option to mac address clone for both wifi interfaces to add mac address clone option for both wifi interfaces

comment:23 Changed 6 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:24 Changed 6 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

broadcom dir-860L A1 also has dupe macs... here too on stock fw the macs are different & correct. even the wan mac is wrong with ddwrt.

comment:25 Changed 6 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

latest build on dir-862L mac clone still changes BOTH radios macs..we need it to change ONE of them, add ability to independently change each radio mac as the concept demonstrated in the screenshot

with dir-860L a1 on latest r30940 the mac clone now works for one of the radios, the 2.4ghz radio. now dupe mac problem is worked around correctly on that unit, with both radios having a different mac.

but on dir-862L the wifi mac change option is still changing both macs at once. this is not d-link's fault, stock firmware has correct (different) macs for all interfaces..

Version 2, edited 6 months ago by tatsuya46 (previous) (next) (diff)

comment:26 Changed 6 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:27 Changed 5 months ago by tatsuya46

remains on r30949

comment:28 Changed 4 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:29 Changed 4 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:30 Changed 3 months ago by mrjcd

r31611 MAC clone adds +1 to wireless by default on WNDR3700v4 see >>> http://mrjcd.com/junk/dd-wrt/WNDR3700v4/r31611-MACs.html

comment:31 Changed 3 months ago by mrjcd

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:32 Changed 3 months ago by mrjcd

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:33 Changed 3 months ago by tatsuya46

for dir-862L, ath0 which is based on ath9k, is used for the ath1 (ath10k) radio mac for some reason. if ath0 is off, like i have on one of my dir-862L's, ath1 will have bogus mac (another ticket), if ath0 is on, both radios have same mac. on stock fw macs are proper & different.

we need mac clone for multiple radios to override this, not just one.

comment:34 Changed 2 months ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:35 Changed 2 months ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:36 Changed 13 days ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:37 Changed 13 days ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.