Opened 6 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#5728 closed (provide more info and reopen)

r7800 client+vap not broadcasting on vht80

Reported by: tatsuya46 Owned by:
Keywords: Cc:

Description

r7800 on r31277 setting client mode on ath0 & making a vap will result in the radio not connecting to the host or broadcasting the vap when ath0 is set to vht80. if i delete the vap it connects to the host fine, or if i leave the vap there & select ht40 instead, it will work.

the host is a dir-862L also on r31277, using vht80 on 161+LL.

r30949 is the last public build where client+vap @ vht80 works fine on r7800.

config screenshots & dmesg below, there is a ath10k start error.

  • [ 24.236807] ath10k_pci 0000:01:00.0: failed to synchronize setup for vdev 0 restart 0: -110
  • [ 24.236876] ath10k_pci 0000:01:00.0: failed to start vdev 0 addr b2:7f:b9:4a:44:be on freq 5220: -110

Attachments (4)

config pt1.png (52.9 KB) - added by tatsuya46 6 weeks ago.
config pt2.png (40.5 KB) - added by tatsuya46 6 weeks ago.
config pt3.png (40.0 KB) - added by tatsuya46 6 weeks ago.
r7800_r31277-dmesg.txt (21.5 KB) - added by tatsuya46 6 weeks ago.

Download all attachments as: .zip

Change History (44)

Changed 6 weeks ago by tatsuya46

Changed 6 weeks ago by tatsuya46

Changed 6 weeks ago by tatsuya46

Changed 6 weeks ago by tatsuya46

comment:1 Changed 6 weeks ago by tatsuya46

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:2 Changed 6 weeks ago by tatsuya46

turns out the vap doesnt even work either when set to ht40 to get the main interface to work. r31170 is the last nightly where client+vap works. the problem starts as of r31186, somewhere between those. looks like in r31174

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:3 Changed 6 weeks ago by tatsuya46

remains on r31388

comment:4 Changed 6 weeks ago by tatsuya46

remains with r31401. works fine on 2.4ghz ht20, ht40, only 5ghz is broken

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:5 Changed 6 weeks ago by BrainSlayer

there is no difference betwen 2.4 or 5 ghz. except for vht80 and vht160 support. code is the same. this makes it more curious. my problem is i dont have many 9984 devices. best is if you would run hostapd with -dd for debugging output and wpa_supplicant as well on different consoles. so terminate them manually and restart them (hostapd first. then start supplicant). i try to setup a testbed here on my side as well.

comment:6 Changed 6 weeks ago by BrainSlayer

found another issue. see r31405

comment:7 Changed 6 weeks ago by tatsuya46

r31412 still not working

Version 0, edited 6 weeks ago by tatsuya46 (next)

comment:8 follow-up: Changed 6 weeks ago by tatsuya46

i think it might be ath10k fw, could u test with 10.4-3.4-00072 & 10.4-3.3-00102? with no other changes besides the fw?

comment:9 Changed 6 weeks ago by tatsuya46

  • Resolution set to invalid
  • Status changed from new to closed

comment:10 Changed 6 weeks ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:11 Changed 6 weeks ago by BrainSlayer

  • Resolution set to worksforme
  • Status changed from reopened to closed

check your testsetup. just tested latest build on my table. sta + vap. as repeater setup. it worked in vht80

comment:12 in reply to: ↑ 8 Changed 6 weeks ago by BrainSlayer

Replying to tatsuya46:

i think it might be ath10k fw, could u test with 10.4-3.4-00072 & 10.4-3.3-00102? with no other changes besides the fw?

latest 3.4 fw is already used

comment:13 Changed 6 weeks ago by BrainSlayer

  • Resolution worksforme deleted
  • Status changed from closed to reopened

i made a small adjustment for 9984 in r31415. which seem to have a positive effekt. i will build now a r7800 test image. give me response if it works for you

comment:14 Changed 6 weeks ago by BrainSlayer

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

comment:15 Changed 6 weeks ago by tatsuya46

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

not fixed. it will connect to the host now, but the vap is not following the host & is stuck on channel 100+106 on wireless status page, but broadcasts itself as 167, which nothing connects to. the host is using 161+155. the connection to the host is abnormally weak and slow too.

also 2.4ghz ht40 now stopped working, always broadcasts in ht20 with this build.

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:16 Changed 6 weeks ago by BrainSlayer

it follows the ap. if ap is operating in ht20, repeater will do so as well. and the vap follows alwaays the host. otherwise it cannot be connected. vap and sta are always on the same channel. remember. its just one radio. no matter what status page shows

comment:17 Changed 6 weeks ago by BrainSlayer

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

comment:18 Changed 6 weeks ago by tatsuya46

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

yes. but that is not the case here. test it on ur r7800 or any qca9984 router. its stuck on channel 100. ur latest change locked the channel to 100. but it still doesnt follow host. even if the host is on channel 161 etc.. the repeater is not following the host here. and also the 2.4ghz radio is now broken, ht40 is broken and never works. last working build is r31170, check it on shellfast. r31170 is last working build for qca9984 repeater, it starts breaking @ r31186.. i think r31174 is where it the problems started.

see my screenshots of config, copy it. u will see easily this problem is not fixed yet.

i know i bothered u for channel fixes, but they are still not correct. and maybe hostapd doesnt understand ur latest changes. but repeating under vht80 is still currently broken. i now depend on this repeater setup for internet, i dont have independent wan anymore, so i can test this easily and quickly.

pls check again.

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:19 follow-up: Changed 6 weeks ago by BrainSlayer

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

okay. i have now 2 r7800 in front of me. first is set to channel 100 uuu. second as repeater both are in vht160. and it works. i will now change the channel of the first one to a different channel. and see what happens.

comment:20 in reply to: ↑ 19 Changed 6 weeks ago by tatsuya46

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

Replying to BrainSlayer:

okay. i have now 2 r7800 in front of me. first is set to channel 100 uuu. second as repeater both are in vht160. and it works. i will now change the channel of the first one to a different channel. and see what happens.

no no.... dont use that. use vht80. set a valid channel such as 36+UU or 161+LL or 144+LL etc.. it will not work at all. or even use 2.4ghz ht40 which is now broken..

sure channel 100 works, but what about all the other channels.?!! they are all broken.

test r31170 on shellfast, it is last working build with ALL channels.. remember ddwrt is violating IEEE 802.11 channel spec, u will be tricked easily on what u think is valid & what isnt, see my channel ticket, look closely, ur logic is flawed & is incorrect for wifi, ur getting confused between these two issues..

hostapd & ath10kfw 9984 is smart, & they know whats invalid and whats valid, that is why they stop working.

please check closely, im not wasting ur time, there is an obvious issue here..! ask ur netgear or dlink, or broadcom, or qualcomm contact even ur mediatek contact, u have broken channel logic.

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:21 Changed 6 weeks ago by BrainSlayer

okay. reproduced what you mean and fixed it in r31429

comment:22 follow-up: Changed 6 weeks ago by BrainSlayer

your channel ticket is not logic. the code i wrote follows the rules from hostapd. unfortunaly the fw does something else. even valid vht160 channels do not work (like channel 104 uuu etc)

comment:23 Changed 6 weeks ago by BrainSlayer

will now make a new test build which i flash on my router. then i will retry the test with ht40

comment:24 Changed 6 weeks ago by BrainSlayer

you may test it with yours. on mine it worked with vht80 on different channels

comment:25 in reply to: ↑ 22 Changed 6 weeks ago by tatsuya46

Replying to BrainSlayer:

your channel ticket is not logic. the code i wrote follows the rules from hostapd. unfortunaly the fw does something else. even valid vht160 channels do not work (like channel 104 uuu etc)

that is not true, cause 104+UUU is NOT, valid.. the 9984 fw is correct. my channel ticket is correct, please look at it closely! ddwrt is going out of bounds on spectrum..please look at this link, it is correct. http://twimgs.com/networkcomputing/news/2013/10/graphic-80211-acChannels-all.png

this example follows wifi spec, u cant violate this or DEVICES wont use 80mhz, pls test this on ur iphone, mac, etc...devices that follow IEEE 802.11 spec DONT FOLLOW ddwrt channel logic, this is the problem here.. example, channel 161 is LOWER LOWER LOWER ONLY, not LOWER UPPER, there is NO space above. another example, channel 60, its LOWER UPPER ONLY, NOT UPPER UPPER ETC... there is NO space for double upper....

i will test with ur latest build.

comment:26 Changed 6 weeks ago by tatsuya46

there is no change. vap still does not follow host, its still stuck on channel 100 only. host is using channel 161!. and now 2.4ghz doesnt work at all, no broadcast with ht40.

comment:27 Changed 6 weeks ago by tatsuya46

r31430 vap is still stuck on channel 100, wrong channel from the host.

comment:28 Changed 6 weeks ago by tatsuya46

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:29 Changed 6 weeks ago by tatsuya46

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:30 Changed 6 weeks ago by tatsuya46

make a host ap on channel etc like 149 or 153 or 161 etc, have ur r7800 use client mode, its still broken, wrong channel used.

comment:31 Changed 6 weeks ago by tatsuya46

vap is still fixed on 100 which is wrong. ht40 on 2.4ghz is still broken.

when i say "fixed" it means broken on a certain value, im not sure if u understand. in english it means set on a certain value. not changing. sorry our language is filled with slang, and is hard to learn.

if the problem is properly "fixed" i will mark the ticket as fixed and not reopen, u understand?

hostapd is WRONG!

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:32 Changed 6 weeks ago by BrainSlayer

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

i tested it. ath0.1 always had the same channel as ath0. no matter which channel i tried in the last version. in the version from yesterday you where right and i was able to see the issue. ht40 worked as well in 2.4 ghz

comment:33 Changed 6 weeks ago by BrainSlayer

for 161 US regulatory i see the issue again. for 140 it worked. lets see what i find out

comment:34 Changed 6 weeks ago by tatsuya46

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

yes. so ticket open till further notice.

comment:35 Changed 6 weeks ago by BrainSlayer

debugging since hours. strange. supplicant sends correct data to hostapd but it wont get accepted. i'm sure i fix that soon within the next hours. just need to find the error in hostapd

comment:36 Changed 6 weeks ago by BrainSlayer

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

watch this r31431. stupidity at its best :-)

comment:37 Changed 6 weeks ago by tatsuya46

  • Resolution provide more info and reopen deleted
  • Status changed from closed to reopened

vht80 repeater is working fine now in r31434. but 2.4ghz still has broken ht40 it only broadcasts ht20. last working build for that is r31412. using 11+lower, haiti.

Last edited 6 weeks ago by tatsuya46 (previous) (diff)

comment:38 Changed 6 weeks ago by BrainSlayer

  • Resolution set to provide more info and reopen
  • Status changed from reopened to closed

this can only be a firmware issue. compare both hostapd configs. you will see that they are identical.

comment:39 Changed 6 weeks ago by BrainSlayer

HT40- fixed in r31438. affects all modes. not just 2.4. but only lower was affected

comment:40 Changed 6 weeks ago by tatsuya46

working again thanks

Note: See TracTickets for help on using tickets.