Opened 3 months ago

Last modified 10 days ago

#5802 reopened

OpenVPN Server Log is Blank r31825 - Various Anomalies -Bytes Received 0, Connected Since Using Bytesout value

Reported by: Shaun Owned by:
Keywords: Cc:

Description

Since i have started using build r31825 on my Archer C7 V2 the OpenVPN Server log under Status>OpenVPN is now blank.

Was this by design as per changeset 31814 or an unintentional side effect?

The OpenVPN log displayed fine on the previous r31791 release.

Attachments (2)

openvpn.jpg (109.0 KB) - added by Shaun 3 months ago.
ddwrt.jpg (83.2 KB) - added by Shaun 2 months ago.

Download all attachments as: .zip

Change History (31)

Changed 3 months ago by Shaun

Attachment: openvpn.jpg added

comment:1 Changed 3 months ago by Shaun

Also should mention, the OpenVPN server is working fine with no issue but just noticed the Server log issue.

Also when one of my devices is successfully connected the Server log is still blank but the details under "Status" display the correct information.

comment:2 Changed 3 months ago by classified

I can confirm this issues with my R7000's and WRT1900's, so this is not just router specific.

comment:3 Changed 2 months ago by mrjcd

Status/OpenVPN server log still blank w/ r31833 & r31839 on EA8500 & WNDR3700v4

comment:4 Changed 2 months ago by mrjcd

Resolution: invalid
Status: newclosed

comment:5 Changed 2 months ago by mrjcd

Resolution: invalid
Status: closedreopened

Remains blank with r31859 Checked w/WNDR3700v4

comment:6 Changed 2 months ago by Handyone

I confirm this issue with my router

Router Model TPLINK WR1043ND V2
Firmware Version DD-WRT v3.0-r31825 std (04/06/17)
Kernel Version Linux 3.18.48 #3078 Thu Apr 6 02:30:55 CEST 2017 mips

comment:8 Changed 2 months ago by Shaun

Summary: OpenVPN Server Log is Blank r31825OpenVPN Server Log is Blank r31825 - Bytes Received Showing 0 all the time

Should also mention i noticed that Bytes Received under VPN Server Status is always 0. Not sure if its by design or been this way for a long time,

comment:9 Changed 2 months ago by Shaun

Resolution: provide more info and reopen
Status: reopenedclosed

comment:10 Changed 2 months ago by Shaun

Resolution: provide more info and reopen
Status: closedreopened

Changed 2 months ago by Shaun

Attachment: ddwrt.jpg added

comment:11 Changed 2 months ago by Shaun

have attached an updated screenc apture from mrjcd's attachment. VPN'd into to my router from work and mine is showing the same anomalies.

Bytes Received is 0, Connected Since is using the value of the bytesout instead of an actual date/time.

comment:12 Changed 2 months ago by Shaun

Summary: OpenVPN Server Log is Blank r31825 - Bytes Received Showing 0 all the timeOpenVPN Server Log is Blank r31825 - Various Anomalies -Bytes Received 0, Connected Since Using Bytesout value

comment:13 Changed 2 months ago by Adam Soffe

Same issue on TP-Link Archer C9v1 so definitely using r31899

Last edited 2 months ago by Adam Soffe (previous) (diff)

comment:14 Changed 2 months ago by mrjcd

Fixed in Kong's r31900M kongat (04/26/17) on EA8500

comment:15 Changed 8 weeks ago by Shaun

Still having these issues in Brainslayers r31923 test build on WRT1900ACSv2

comment:16 Changed 8 weeks ago by Shaun

Resolution: provide more info and reopen
Status: reopenedclosed

comment:17 Changed 8 weeks ago by Shaun

Resolution: provide more info and reopen
Status: closedreopened

comment:18 Changed 3 weeks ago by mrjcd

Resolution: provide more info and reopen
Status: reopenedclosed

comment:19 Changed 3 weeks ago by mrjcd

Resolution: provide more info and reopen
Status: closedreopened

Remains w/ r32170 (broadcom & atheros) No log & No config for openVPN server on page .../Status_OpenVPN.asp

comment:20 Changed 3 weeks ago by BrainSlayer

not reproducable. just tested. please fix your config for management port and it will work

comment:21 Changed 3 weeks ago by BrainSlayer

Resolution: invalid
Status: reopenedclosed

comment:22 Changed 3 weeks ago by mrjcd

Resolution: invalid
Status: closedreopened

comment:23 Changed 3 weeks ago by mrjcd

EA8500 r32216 openVPN Server works great but log on status still needs fine tuning.

http://mrjcd.com/junk/r32216_VPNServerLog.png

comment:24 Changed 3 weeks ago by Shaun

I have also advised Brainslayer and i can also see in your screenshot the bytes received is always 0 and the connected since is not a date. Clearly these cannot be correct values.

comment:25 in reply to:  24 Changed 3 weeks ago by mrjcd

Replying to shauno10:

I have also advised Brainslayer and i can also see in your screenshot the bytes received is always 0 and the connected since is not a date. Clearly these cannot be correct values.

Thanks shauno10
openVPN server fine but same bad status -- tested with -
Netgear WNDR3700 V4
DD-WRT v3.0-r32225 std (06/05/17)
Linux 3.18.55 #4547 Mon Jun 5 14:47:18 CEST 2017 mips http://mrjcd.com/junk/dd-wrt/WNDR3700v4/wndr3700v4-VPN.png

comment:26 Changed 3 weeks ago by Shaun

Resolution: invalid
Status: reopenedclosed

comment:27 Changed 3 weeks ago by Shaun

Resolution: invalid
Status: closedreopened

comment:28 Changed 10 days ago by mrjcd

Resolution: provide more info and reopen
Status: reopenedclosed

comment:29 Changed 10 days ago by mrjcd

Resolution: provide more info and reopen
Status: closedreopened

r32321
openVPN server working ok but status page is now null
see >>> http://mrjcd.com/junk/dd-wrt/r32321_ovpnstatus/

Note: See TracTickets for help on using tickets.