Opened 6 weeks ago

Last modified 2 weeks ago

#5807 new

ebtable issue

Reported by: diabolo Owned by:
Keywords: Cc:

Description

I have problem with Ebtable which bug and can consume lot of CPU on RT-18N. Example when you tried to run the script

/tmp/openvpn/route-up.sh

The cpu is fully use for this process :

usr/sbin/ebtables -t nat -D POSTROUTING -o tap1 --pkttype-type multicast -j DROP

When you tried to just type Ebtable to get help, the command is running but nothing happen. The package ebtables seem to be well loaded

I have tested this build, all of them have this issue. 03-21-2017-r31722/ 03-30-2017-r31791/ 04-06-2017-r31825/

Change History (7)

comment:1 follow-up: Changed 6 weeks ago by diabolo

DD-WRT v3.0-r30471 std (08/24/16) ==> Works well

comment:2 in reply to: ↑ 1 Changed 6 weeks ago by diabolo

Replying to diabolo:

DD-WRT v3.0-r30471 std (08/24/16) ==> Works well

DD-WRT v3.0-r30949 std (12/15/16) ==> Works well (not for openvpn)

comment:3 Changed 6 weeks ago by diabolo

DD-WRT v3.0-r31533 std (02/27/17) ==> Have this issue

comment:4 Changed 6 weeks ago by diabolo

DD-WRT v3.0-r31221 std (02/01/17) ==> have also issue.

The problem was coming during modification between 2016-12-15 and 2017-02-01.

comment:5 Changed 6 weeks ago by Ludacrisvp

As there seems to be a separate bug tracker from this one that contain different issues I'm adding that relevant info here. https://www.dd-wrt.com/dd-wrtv2/bugtracker/view.php?id=4830

Reporter: hawk2001

Summary:

0004830: ebtables hangs

Description:

This is present in the current build v3.0-r31791 std (sorry if it's miscategorized I didn't see a v3 option). Any interaction with ebtables causes 100% cpu load and is otherwise unresponsive. When executed as part of OpenVPN's nat drop rules, or via CLI the behavior is the same. This was on a Netgear R7000.

(0011796)

Ludacrisvp

Also seeing this on build v3.0-r31722 std (03/21/17) So not sure how long this has been an issue but it goes back to at least that version. This is on Buffalo WXR-1900DHP which has dual core 1Ghz BCM4709 and 'ebtables' is using all of one core.

"top" process info shows it is running on this core, the %CPU in the output of top seems to be scaled to max at 100% vs being able to go to 200% like other multi core capable OS.

I've killed the process and rebooted many times, it always comes back to "100%" CPU instantly every time so it is 100% reproducible. This started coming up now that I started using OpenVPN directly on the router instead of on each device.

Mem: 56904K used, 457788K free, 0K shrd, 6976K buff, 18852K cached

CPU0: 99.6% usr 0.0% sys 0.0% nic 0.0% idle 0.0% io 0.0% irq 0.3% sirq <- CPU0 pegged

CPU1: 5.3% usr 0.7% sys 0.0% nic 92.0% idle 0.0% io 0.0% irq 1.7% sirq

Load average: 1.26 1.28 1.56 2/95 5623

PID PPID USER STAT VSZ %VSZ CPU %CPU COMMAND

5294 5293 root R 768 0.1 0 49.8 /usr/sbin/ebtables -t nat -D POSTROUTING -o tap1 --pkttype-type multicast -j DROP

comment:6 Changed 4 weeks ago by diabolo

I have tested the last version DD-WRT v3.0-r31899 std (04/24/17)

I got the same issue with Ebtables.

comment:7 Changed 2 weeks ago by diabolo

I have tested the version DD-WRT v3.0-r31924 std (05/03/17)

I got the same issue with Ebtables.

Note: See TracTickets for help on using tickets.